Загрузка

Передача результатов запроса в управляемую форму 1С

NNS Team / Заметки разработчика

Задача состоит вывести таблицу по результатах запроса в отрытой форме.

Код для формы с которой будем вызывать открытие новой формы и заполнять таблицу

&НаКлиенте
Процедура ПоказатьНулевыеОстатки(Команда)
    Табл = ПоказатьНулевыеОстаткиНаСервере();
    П = Новый Структура("ОстаткиНулевые", Табл);
    ФормаОстатков = ПолучитьФорму("Документ.ЧекККМ.Форма.ФормаОстаткиНулевые",П);
    ФормаОстатков.Открыть();
  КонецПроцедуры
 

&НаСервере
Функция ПоказатьНулевыеОстаткиНаСервере()
                     
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "  текст запроса";

    РезультатЗапроса = Запрос.Выполнить();
  
    Результат = РезультатЗапроса.Выгрузить();
    
    Возврат Результат;

КонецФункции
 

В форме, которую открываем, добавляем одну процедуру. Параметры заполнять не нужно. Название колонок должно соответствовать запросу.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
     ТаблЗнач = Параметры.ОстаткиНулевые;
     ЭтотОбъект.ОстаткиНулевые.Загрузить(ТаблЗнач);      
КонецПроцедуры 

Передача результатов запроса в управляемую форму 1С
28-02-2017 22:02:00
Просмотры: 871/240

Комментарии

Комментарии отсуствуют